using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\*[A-Z]{3}:)";
string input = @"*TOB: hola estamos aquí porque hemos recibido cinco mil euros y tenemos que: decidir (.) qué hacemos con este dinero (.) yo propongo que con este dinero pagamos actividades para que: los estudiantes se conocen y para que aprenden cómo: formar una comunidad un equipo por eso propongo que: pagamos actividades como paintball lastertag o:: m:: a lo mejor una excursión a port aventura para que los estudiantes se pueden conocer y pueden: (.) crecer amis- amistades y tal ¿qué os parece?
*MIN: pue::s ¿de cuán dinero hablamos?
*PPP: (0.9)
*TOB: mh ¿perdón?=";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}