const regex = /\b(?!п?ос[л|к][а|о]р?бляе?т?ь?л?)\w*бля\w*|(\w*бляд\w*)|(\w*ху[й|и|е|ё|я|]\w*)|\b(хули)\b|([е|ё]{1,}пт[а|и|е|о]?\b)|([до]\w*[ё|е]б)|(пизд\w*)|(пид[а|о|е]р\w*)|(пид[е|а|о]р)|(пидр?[\w]{1,}\b)|(гандон\w*)|\b(?!нё)(\w*[е|ё]б[а|о|и|н]\w*)|(еб[е|ё|а|у|н]\w*)|(\w*еб[а]\w*)|(\w*[у|е|за]{1,2}[е|ё]б)|\b(?!\w)\s(ёб)\s/gsimu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!п?ос[л|к][а|о]р?бляе?т?ь?л?)\\w*бля\\w*|(\\w*бляд\\w*)|(\\w*ху[й|и|е|ё|я|]\\w*)|\\b(хули)\\b|([е|ё]{1,}пт[а|и|е|о]?\\b)|([до]\\w*[ё|е]б)|(пизд\\w*)|(пид[а|о|е]р\\w*)|(пид[е|а|о]р)|(пидр?[\\w]{1,}\\b)|(гандон\\w*)|\\b(?!нё)(\\w*[е|ё]б[а|о|и|н]\\w*)|(еб[е|ё|а|у|н]\\w*)|(\\w*еб[а]\\w*)|(\\w*[у|е|за]{1,2}[е|ё]б)|\\b(?!\\w)\\s(ёб)\\s', 'gsimu')
const str = `бля блять блядь блядина выблядок сракоблять сракоблядь оскарблять оскорблять блядосрака бляцкий блятский блядский блцк ослаблять ослабляет оскарбляет ослоблял ослаблял осбаляет оскарблять оскарблядь ослоблядь ослоблядит послаблять
хуй хуило хуйло хуево хуёво хуже хуев хуи хуевая хуёвая хуёвый хуятина хули хулио
ебать заебал уебок уебище уебан уёбан уёбок ёб нёбо гёрб захлёб уебался заебал уебал ебать ёпта ёпт епта епт епти ёпти ёпто ебучие еб ебнутый ебется ебётся долбаёб долбаеб ебал ёбнутый ебанат ебанклаус грёб в захлёб заебался
пизда пизданулся пиздец пиздос пиздатый пизд пиздюк
пидр пидор пидар пидер пидарас пидорас пидерас пидераст пидараст пидораст пидрила пидрило
гандон гандонина`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}