#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?simu)\b(?!п?ос[л|к][а|о]р?бляе?т?ь?л?)\w*бля\w*|(\w*бляд\w*)|(\w*ху[й|и|е|ё|я|]\w*)|\b(хули)\b|([е|ё]{1,}пт[а|и|е|о]?\b)|([до]\w*[ё|е]б)|(пизд\w*)|(пид[а|о|е]р\w*)|(пид[е|а|о]р)|(пидр?[\w]{1,}\b)|(гандон\w*)|\b(?!нё)(\w*[е|ё]б[а|о|и|н]\w*)|(еб[е|ё|а|у|н]\w*)|(\w*еб[а]\w*)|(\w*[у|е|за]{1,2}[е|ё]б)|\b(?!\w)\s(ёб)\s"
Local $sString = "бля блять блядь блядина выблядок сракоблять сракоблядь оскарблять оскорблять блядосрака бляцкий блятский блядский блцк ослаблять ослабляет оскарбляет ослоблял ослаблял осбаляет оскарблять оскарблядь ослоблядь ослоблядит послаблять" & @CRLF & _
"" & @CRLF & _
"хуй хуило хуйло хуево хуёво хуже хуев хуи хуевая хуёвая хуёвый хуятина хули хулио" & @CRLF & _
"" & @CRLF & _
"ебать заебал уебок уебище уебан уёбан уёбок ёб нёбо гёрб захлёб уебался заебал уебал ебать ёпта ёпт епта епт епти ёпти ёпто ебучие еб ебнутый ебется ебётся долбаёб долбаеб ебал ёбнутый ебанат ебанклаус грёб в захлёб заебался " & @CRLF & _
"" & @CRLF & _
"пизда пизданулся пиздец пиздос пиздатый пизд пиздюк " & @CRLF & _
"" & @CRLF & _
"пидр пидор пидар пидер пидарас пидорас пидерас пидераст пидараст пидораст пидрила пидрило" & @CRLF & _
"" & @CRLF & _
"гандон гандонина"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")