# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(www.ibm.com\/(.*-.*|products)\/(dynamed-and-micromedex-with-watson|flexible-analytics|iconnect-enterprise-archive|iconnect-access|medication-essential-fact-sheets|merge-cardio|merge-hemo|merge-pacs|micromedex-carenotes|micromedex-content-api|micromedex-neofax-pediatrics|micromedex-red-book|micromedex-with-watson|orbitalrx|watson-assistant-health-benefits|watson-care-manager|watson-health-citizen-engagement))|(www.ibm.com\/(.*-.*|watson-health)\/(about|solutions)\/(social-program-management|micromedex))"
test_str = ("www.ibm.com/products/flexible-analytics\n"
"www.ibm.com/products/watson-assistant-health-benefits\n"
"www.ibm.com/watson-health/about/micromedex\n"
"www.ibm.com/products/micromedex-with-watson\n"
"www.ibm.com/products/dynamed-and-micromedex-with-watson\n"
"www.ibm.com/products/orbitalrx\n"
"www.ibm.com/products/micromedex-content-api\n"
"www.ibm.com/products/micromedex-red-book\n"
"www.ibm.com/products/micromedex-carenotes\n"
"www.ibm.com/products/medication-essential-fact-sheets\n"
"www.ibm.com/products/micromedex-neofax-pediatrics\n"
"www.ibm.com/watson-health/solutions/social-program-management\n"
"www.ibm.com/products/watson-care-manager\n"
"www.ibm.com/products/watson-health-citizen-engagement\n"
"www.ibm.com/products/iconnect-enterprise-archive\n"
"www.ibm.com/products/iconnect-access\n"
"www.ibm.com/products/merge-hemo\n"
"www.ibm.com/products/merge-cardio\n"
"www.ibm.com/products/merge-pacs")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.