#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(www.ibm.com\/(.*-.*|products)\/(dynamed-and-micromedex-with-watson|flexible-analytics|iconnect-enterprise-archive|iconnect-access|medication-essential-fact-sheets|merge-cardio|merge-hemo|merge-pacs|micromedex-carenotes|micromedex-content-api|micromedex-neofax-pediatrics|micromedex-red-book|micromedex-with-watson|orbitalrx|watson-assistant-health-benefits|watson-care-manager|watson-health-citizen-engagement))|(www.ibm.com\/(.*-.*|watson-health)\/(about|solutions)\/(social-program-management|micromedex))"
Local $sString = "www.ibm.com/products/flexible-analytics" & @CRLF & _
"www.ibm.com/products/watson-assistant-health-benefits" & @CRLF & _
"www.ibm.com/watson-health/about/micromedex" & @CRLF & _
"www.ibm.com/products/micromedex-with-watson" & @CRLF & _
"www.ibm.com/products/dynamed-and-micromedex-with-watson" & @CRLF & _
"www.ibm.com/products/orbitalrx" & @CRLF & _
"www.ibm.com/products/micromedex-content-api" & @CRLF & _
"www.ibm.com/products/micromedex-red-book" & @CRLF & _
"www.ibm.com/products/micromedex-carenotes" & @CRLF & _
"www.ibm.com/products/medication-essential-fact-sheets" & @CRLF & _
"www.ibm.com/products/micromedex-neofax-pediatrics" & @CRLF & _
"www.ibm.com/watson-health/solutions/social-program-management" & @CRLF & _
"www.ibm.com/products/watson-care-manager" & @CRLF & _
"www.ibm.com/products/watson-health-citizen-engagement" & @CRLF & _
"www.ibm.com/products/iconnect-enterprise-archive" & @CRLF & _
"www.ibm.com/products/iconnect-access" & @CRLF & _
"www.ibm.com/products/merge-hemo" & @CRLF & _
"www.ibm.com/products/merge-cardio" & @CRLF & _
"www.ibm.com/products/merge-pacs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")