re = /([Jj]an(uary)?|[Ff]eb(ruary)?|[Mm]ar(ch)?|[Aa]pr(il)?|[Mm]ay|[Jj]un(e)?|[Jj]ul(y)?|[Aa]ug(ust)?|[Ss]ep(t(ember)?)?|[Oo]ct(ober)?|[Nn]ov(ember)?|[Dd]ec(ember)?)((0[1-9])|([12][0-9])|(3[01])|[1-9]){1}
/
str = 'jul20
october2
December9
nov10
jun49
August09
Jan12
Sep11
Sept12
September14
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end