using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([Jj]an(uary)?|[Ff]eb(ruary)?|[Mm]ar(ch)?|[Aa]pr(il)?|[Mm]ay|[Jj]un(e)?|[Jj]ul(y)?|[Aa]ug(ust)?|[Ss]ep(t(ember)?)?|[Oo]ct(ober)?|[Nn]ov(ember)?|[Dd]ec(ember)?)((0[1-9])|([12][0-9])|(3[01])|[1-9]){1}
";
string input = @"jul20
october2
December9
nov10
jun49
August09
Jan12
Sep11
Sept12
September14
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}