package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z][a-z]{2}\s\d\s\d\d:[\d]{2}:[\d]{2})\s([\w]+[\.][\w]+)\s([\w|=]+)(\[\d+\]):\s.+[\(|\s|\\|\"]`)
var str = `Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)
Jul 6 14:02:08 computer.name jam_tag=psim[29187]: (UUID:006)
Jul 6 14:02:09 computer.name jam_tag=psim[29187]: (UUID:007)
Jul 6 14:03:01 computer.name CRON[29440]: USER (naughty_user)
Jul 6 14:03:40 computer.name cacheclient[29807]: start syncing from \"0xDEADBEEF\"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}