#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z][a-z]{2}\s\d\s\d\d:[\d]{2}:[\d]{2})\s([\w]+[\.][\w]+)\s([\w|=]+)(\[\d+\]):\s.+[\(|\s|\\|\"]"
Local $sString = "Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)" & @CRLF & _
"Jul 6 14:02:08 computer.name jam_tag=psim[29187]: (UUID:006)" & @CRLF & _
"Jul 6 14:02:09 computer.name jam_tag=psim[29187]: (UUID:007)" & @CRLF & _
"Jul 6 14:03:01 computer.name CRON[29440]: USER (naughty_user)" & @CRLF & _
"Jul 6 14:03:40 computer.name cacheclient[29807]: start syncing from \"0xDEADBEEF\""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")