# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9]"
test_str = ("Valid domain name matching.\n"
"Vote for it: http://stackoverflow.com/a/30007882/697313\n\n"
"Sample text for testing:\n"
"abcdefghijklmnopqrstuvwxyz.ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
"0123456789 +-.,!@#$%^&*();\\\\/|<>\\\"\\'\n"
"12345 -98.7 3.141 .6180 9,000 +42\n"
"555.123.4567 +1-(800)-555-2468\n"
"foodemo.net\n"
"bar.ba.test.co.uk\n"
"www.demo.com\n"
"http://foo.co.uk/\n"
"http://regexr.com/foo.html?q=bar\n"
"g.com\n"
"g-.com\n"
"com.g\n"
"-g.com\n"
"xn--d1ai6ai.xn--p1ai\n"
"xn-fsqu00a.xn-0zwm56d\n"
"xn--stackoverflow.com\n"
"stackoverflow.xn--com\n"
"stackoverflow.co.uk\n"
"google.com.au\n\n"
"-0-0o.com\n"
"0-0o_.com (underscore not allowed)\n"
"a.net\n"
"-a.dot\n"
"0-0o.com\n"
"0-oz.co.uk\n"
"0-tension.com.br\n"
"0-wh-ao14-0.com-com.net\n"
"a-1234567890-1234567890-1234567890-1234567890-1234567890-1234-z.eu.us\n"
"a-1234567890-1234567890-1234567890-1234567890-1234567890-12345-z.eu.us (too long)\n\n"
"List of valid domain names:\n"
"www.google.com\n"
"google.com\n"
"mkyong123.com\n"
"mkyong-info.com\n"
"sub.mkyong.com\n"
"sub.mkyong-info.com\n"
"mkyong.com.au\n"
"g.co\n"
"mkyong.t.t.co\n\n"
"List of invalid domain names, and why:\n"
"mkyong.t.t.c – Tld must between 2 and 6 long\n"
"mkyong,com – Comma is not allow\n"
"mkyong – No Tld\n"
"mkyong.123 , Tld not allow digit (can easily fix for this)\n"
".com – Must start with [A-Za-z0-9]\n"
"mkyong.com/users – No Tld\n"
"-mkyong.com – Cannot begin with a hyphen -\n"
"mkyong-.com – Cannot end with a hyphen -\n"
"sub.-mkyong.com – Cannot begin with a hyphen -\n"
"sub.mkyong-.com – Cannot end with a hyphen -\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.