#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9]"
Local $sString = "Valid domain name matching." & @CRLF & _
"Vote for it: http://stackoverflow.com/a/30007882/697313" & @CRLF & _
"" & @CRLF & _
"Sample text for testing:" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz.ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789 +-.,!@#$%^&*();\\/|<>\"\'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foodemo.net" & @CRLF & _
"bar.ba.test.co.uk" & @CRLF & _
"www.demo.com" & @CRLF & _
"http://foo.co.uk/" & @CRLF & _
"http://regexr.com/foo.html?q=bar" & @CRLF & _
"g.com" & @CRLF & _
"g-.com" & @CRLF & _
"com.g" & @CRLF & _
"-g.com" & @CRLF & _
"xn--d1ai6ai.xn--p1ai" & @CRLF & _
"xn-fsqu00a.xn-0zwm56d" & @CRLF & _
"xn--stackoverflow.com" & @CRLF & _
"stackoverflow.xn--com" & @CRLF & _
"stackoverflow.co.uk" & @CRLF & _
"google.com.au" & @CRLF & _
"" & @CRLF & _
"-0-0o.com" & @CRLF & _
"0-0o_.com (underscore not allowed)" & @CRLF & _
"a.net" & @CRLF & _
"-a.dot" & @CRLF & _
"0-0o.com" & @CRLF & _
"0-oz.co.uk" & @CRLF & _
"0-tension.com.br" & @CRLF & _
"0-wh-ao14-0.com-com.net" & @CRLF & _
"a-1234567890-1234567890-1234567890-1234567890-1234567890-1234-z.eu.us" & @CRLF & _
"a-1234567890-1234567890-1234567890-1234567890-1234567890-12345-z.eu.us (too long)" & @CRLF & _
"" & @CRLF & _
"List of valid domain names:" & @CRLF & _
"www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"mkyong123.com" & @CRLF & _
"mkyong-info.com" & @CRLF & _
"sub.mkyong.com" & @CRLF & _
"sub.mkyong-info.com" & @CRLF & _
"mkyong.com.au" & @CRLF & _
"g.co" & @CRLF & _
"mkyong.t.t.co" & @CRLF & _
"" & @CRLF & _
"List of invalid domain names, and why:" & @CRLF & _
"mkyong.t.t.c – Tld must between 2 and 6 long" & @CRLF & _
"mkyong,com – Comma is not allow" & @CRLF & _
"mkyong – No Tld" & @CRLF & _
"mkyong.123 , Tld not allow digit (can easily fix for this)" & @CRLF & _
".com – Must start with [A-Za-z0-9]" & @CRLF & _
"mkyong.com/users – No Tld" & @CRLF & _
"-mkyong.com – Cannot begin with a hyphen -" & @CRLF & _
"mkyong-.com – Cannot end with a hyphen -" & @CRLF & _
"sub.-mkyong.com – Cannot begin with a hyphen -" & @CRLF & _
"sub.mkyong-.com – Cannot end with a hyphen -" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")