re = /^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]){4}\d{25}[0-9]{1}\d{12}([1-9]|[1-9][0-9]|[1-9][0-9][0-9])$/m
str = '26090837916945379538252700000004491630000002580'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end