$re = '/^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]){4}\d{25}[0-9]{1}\d{12}([1-9]|[1-9][0-9]|[1-9][0-9][0-9])$/m';
$str = '26090837916945379538252700000004491630000002580';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);