$re = '/[1-9]{0,}/m';
$str = '001234567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);