package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-9]{0,}`)
var str = `001234567890
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}