re = /(?:\{#([a-z0-9_\-]+)|(?<!^)\G)\[([^\[\]]+)\](?=[^{}]*\})/
str = '{#array[index1][index2][index3]}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result