const regex = /(?:\{#([a-z0-9_\-]+)|(?<!^)\G)\[([^\[\]]+)\](?=[^{}]*\})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\{#([a-z0-9_\\-]+)|(?<!^)\\G)\\[([^\\[\\]]+)\\](?=[^{}]*\\})', 'g')
const str = `{#array[index1][index2][index3]}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);