$re = '/^([\+]{0,1})([\d\s]{0,15})$/';
$str = '+48 123 456 987 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);