package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\+]{0,1})([\d\s]{0,15})$`)
var str = `+48 123 456 987 `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}