re = /@(?<name>\w+)\W([\w\W]+)!(?<type>G|N)!/
str = '@Kate^jfdvbkrjgb!G!
@Bobbie*kjdrrbgk!G!
@Stan#dkjghskd!N!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end