package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(?<name>\w+)\W([\w\W]+)!(?<type>G|N)!`)
var str = `@Kate^jfdvbkrjgb!G!
@Bobbie*kjdrrbgk!G!
@Stan#dkjghskd!N!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}