package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[a-z]+:\sname="[a-zA-Z]+"\scontent=".+"\s(?:\/|)>`)
var str = `<a: name="Var" content="Value" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}