re = /\[(youtube )(\s*)([http:\/\/(?:www\.)?youtube.com\/watch\?(?=.*v=\w+)(?:\S+)?$]+)\]/
str = '[youtube http://www.youtube.com/watch?v=XpsDr1qePxA]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end