$re = '/\[(youtube )(\s*)([http:\/\/(?:www\.)?youtube.com\/watch\?(?=.*v=\w+)(?:\S+)?$]+)\]/';
$str = '[youtube http://www.youtube.com/watch?v=XpsDr1qePxA]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);