// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\W|^\d|^[A-Z ]+$|^[tT]able.+|^[Ff]igure.+|^[fF][aA][Xx].+|^[Ee]mail.+|^EMAIL.+|\.[\w]+\.|\d[\+\-\\\*\/]\d|[\(\)\+\-\\\*\/] [\(\)\+\-\\\*\/]").unwrap();
let string = "AL SJ
alias56 45 5
23
table 3
I love my mom (YES)
(123)
EMAIL
email :
Fig.2.3.
a.b.b.
Model ES2/50/600 ALD Vacuum Technology will be operated in December 2007
International Price Ex) \\1,000,000
(1985) An almost ideal demand system for visitor expenditures, Journal of Transport Economics and Policy, Vol.19, No.2, 161-171
Then he gave advice to Morgenstern not to pay too much respect to the Austrian tradition and to go on with his own belief of the impossibility of forecasting
Head Office & Plant: 3-20, 1-chome, Higashisuna, Koto-ku, Tokyo 136-0074
micro-amanlysis of ther fh ehif wnf . ejf-e weew e$ kgejg ^%&%^ ekjwe843759843 iy3ty dfgmdbkjjkdg73 dg gh
This study applies the Repeated Discrete Choice Model (hereafter RDC) as one of (.
.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}