#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\W|^\d|^[A-Z ]+$|^[tT]able.+|^[Ff]igure.+|^[fF][aA][Xx].+|^[Ee]mail.+|^EMAIL.+|\.[\w]+\.|\d[\+\-\\\*\/]\d|[\(\)\+\-\\\*\/] [\(\)\+\-\\\*\/]"
Local $sString = "AL SJ " & @CRLF & _
"alias56 45 5" & @CRLF & _
"23 " & @CRLF & _
"" & @CRLF & _
"table 3" & @CRLF & _
"I love my mom (YES)" & @CRLF & _
"(123)" & @CRLF & _
"" & @CRLF & _
"EMAIL" & @CRLF & _
"email :" & @CRLF & _
"Fig.2.3." & @CRLF & _
"a.b.b." & @CRLF & _
"" & @CRLF & _
"Model ES2/50/600 ALD Vacuum Technology will be operated in December 2007" & @CRLF & _
"" & @CRLF & _
"International Price Ex) \1,000,000" & @CRLF & _
"" & @CRLF & _
"(1985) An almost ideal demand system for visitor expenditures, Journal of Transport Economics and Policy, Vol.19, No.2, 161-171" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Then he gave advice to Morgenstern not to pay too much respect to the Austrian tradition and to go on with his own belief of the impossibility of forecasting" & @CRLF & _
"" & @CRLF & _
"Head Office & Plant: 3-20, 1-chome, Higashisuna, Koto-ku, Tokyo 136-0074" & @CRLF & _
"" & @CRLF & _
"micro-amanlysis of ther fh ehif wnf . ejf-e weew e$ kgejg ^%&%^ ekjwe843759843 iy3ty dfgmdbkjjkdg73 dg gh" & @CRLF & _
"" & @CRLF & _
"This study applies the Repeated Discrete Choice Model (hereafter RDC) as one of (." & @CRLF & _
"" & @CRLF & _
"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")