$re = '/^(((1)?(\d{3})?(\d{7})$)|((1-)?(\d{3}?-)(\d{3})-(\d{4}))|(((1)?\((\d{3})\))?(\d{3})-?(\d{4})))$/A';
$str = '1(262)877-3389';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);