using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((1)?(\d{3})?(\d{7})$)|((1-)?(\d{3}?-)(\d{3})-(\d{4}))|(((1)?\((\d{3})\))?(\d{3})-?(\d{4})))$";
string input = @"1(262)877-3389";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}