import Foundation
let pattern = #"([1X2])(?!\1)([1X2])(?!\2|\1)[1X2]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"X121X2X21X1X2X2X11X112X"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}