$re = '/([1X2])(?!\1)([1X2])(?!\2|\1)[1X2]/';
$str = 'X121X2X21X1X2X2X11X112X';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);