// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{1,9})?$").unwrap();
let string = "120000.343123
120000.2
12,000,000,000.122212121";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}