const regex = /^[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{1,9})?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,3}(?:,?[0-9]{3})*(?:\\.[0-9]{1,9})?$', 'gmi')
const str = `120000.343123
120000.2
12,000,000,000.122212121`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}