$re = '/(?:^|\,{1,})(foobar)(?:$|\,{1,})/';
$str = 'foobar,sdf,sdffoobar,foobar,foobarads,foobar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);