using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\,{1,})(foobar)(?:$|\,{1,})";
string input = @"foobar,sdf,sdffoobar,foobar,foobarads,foobar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}