re = /(?<=[_])\d{1}(?=\.)/m
str = '001 Astro_1.jpeg
001 Astro_34.jpeg
001 Astro_427.jpeg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end