$re = '/(?<=[_])\d{1}(?=\.)/m';
$str = '001 Astro_1.jpeg
001 Astro_34.jpeg
001 Astro_427.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);