re = /LogFile Alert: Pattern 'Memory queue for message type 1: 3038' found /
str = 'LogFile Alert: Pattern \'Memory queue for message type 1: 3038\' found in /var/log/me'
# Print the match result
str.match(re) do |match|
puts match.to_s
end