$re = '/LogFile Alert: Pattern \'Memory queue for message type 1: 3038\' found /';
$str = 'LogFile Alert: Pattern \'Memory queue for message type 1: 3038\' found in /var/log/me';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);