$re = '/\b(?=\w{4,}\D)(beautifül tree|[äöüÄÖÜß\w]+.*?)\b/i';
$str = '<a href="http://www.webongo.de" rel="follow">webdesign von experten</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);