using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=\w{4,}\D)(beautifül tree|[äöüÄÖÜß\w]+.*?)\b";
string input = @"<a href=""http://www.webongo.de"" rel=""follow"">webdesign von experten</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}