re = /(?:^\s*[-+*^]|[-+*^]\s*[-+*^]|[xX]\s*[xX]|[-+*^]\s*$)/
str = '+ 5 + 4 * X + X^2 - 2 + X^2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end