using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\s*[-+*^]|[-+*^]\s*[-+*^]|[xX]\s*[xX]|[-+*^]\s*$)";
string input = @"+ 5 + 4 * X + X^2 - 2 + X^2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}