$re = '/^(?!.*\d)[a-z\p{Arabic}\s]{2,66}$/ui';
$str = 'محمود علي قاسم';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);