const regex = /^(?!.*\d)[a-z\p{Arabic}\s]{2,66}$/ui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\d)[a-z\\p{Arabic}\\s]{2,66}$', 'ui')
const str = `محمود علي قاسم`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}