$re = '/(?i)(?<=\/)pathElement(?=\/)/m';
$str = 'https://www.host.com/pathElement/index.html
https://www.host.com/context/pathElement/index.html
https://www.host.com/context/subContext/pathElement/index.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);