using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<=\/)pathElement(?=\/)";
string input = @"https://www.host.com/pathElement/index.html
https://www.host.com/context/pathElement/index.html
https://www.host.com/context/subContext/pathElement/index.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}