# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<FIELDTYPE>[А-Яа-я. ]+){0,1}(,[ ]*+(?<QUALITY>[А-Яа-я. ]+)){0,1}(,[ ]*+(?<FIELDCONDITION>[А-Яа-я ]+)){0,1}(,[ ]*+заросший[ ]+(?<OVERGROWINGCOVERAGE>\d+)%?[ ]*(?<OVERGROWINGTS>[А-Яа-я .]+)){0,1}(,[ ]*+урожайность[ ]*+(?<PRODUCTIVITY>(\d+,\d+))[ ]*+(т\/га)?){0,1}(,[ ]*+(?<USERTYPE>[А-Яа-я .]+|(\d+))){0,1}$"
test_str = ("заливной,чистый,заросший 30% ИВА КУСТАРНИКО,урожайность 1,0 т/га\n"
"суходольный,низкого качества,покрытый кочками,заросший 10% береза белая,урожайность 0,6 т/га,подсобное хозяйство\n"
"заболоченный,среднего качества,покрытый кочками,заросший 20% ольха кустарни,урожайность 0,5 т/га,служеб.надел раб.и сл.\n"
"ЗАЛИВНОЙ,КОРЕННОГО УЛУЧШЕНИЯ,заросший 10% ИВА ДРЕВОВИДНА,урожайность 0,5 т/га\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЧИСТЫЙ ,урожайность 1,5 т/га,СЛУЖЕБ.НАДЕЛ РАБ.И СЛ.\n"
"заболоченный,среднего качества,покрытый кочками,заросший 5% ольха,урожайность 2,0 т/га,служеб.надел раб.и сл.\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 10% СПИРЕЯ,урожайность 0,3 т/га,СЛУЖЕБ.НАДЕЛ РАБ.И СЛ.\n"
"суходольный,низкого качества,заросший,заросший 40% Спирея,урожайность 0,1 т/га,Фонд администрации\n"
"суходольный,среднего качества,чистый ,урожайность 0,5 т/га,Фонд администрации\n"
"заболоченный,среднего качества,заросший,заросший 5% Осина,урожайность 0,7 т/га,Служ.надел раб. и служ.\n"
"заливной,низкого качества,покрытый кочками,заросший 20% ива.древовидна,урожайность 10,0 т/га,служеб.надел лесной охр.\n"
"суходольный,среднего качества,чистый ,урожайность 1,0 т/га,фонд рик\n"
"заболоченный,среднего качества,покрытый кочками,заросший 30% Береза белая,урожайность 1,0 т/га,Фонд администрации\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 40% БЕРЕЗА,урожайность 0,5 т/га,ФОНД АДМИНИСТР.РАЙОНА\n"
"суходольный,среднего качества,чистый,заросший 10% Береза белая,урожайность 1,0 т/га,Фонд администрации\n"
"заболоченный,среднего качества,заросший,заросший 10% Ива,урожайность 0,5 т/га,Служеб.надел лесн. охр.\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 10% СПИРЕЯ,урожайность 0,3 т/га,СЛУЖЕБ.НАДЕЛ РАБ.И СЛ.\n"
"заболоченный\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 20% ИВА КУСТАРНИК.,урожайность 0,6 т/га,ФОНД АДМИНИСТР.РАЙОНА\n"
"заболоченный,среднего качества,заросший,заросший 10% Ива,урожайность 0,5 т/га,Служеб.надел лесн. охр.\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 40% БЕРЕЗА,урожайность 0,5 т/га,СЛУЖЕБ.НАДЕЛ ЛЕСНОЙ ОХР.\n"
"СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 30% БЕРЕЗА,урожайность 0,6 т/га,ФОНД АДМИНИСТР.РАЙОНА\n"
"ЗАЛИВНОЙ,СРЕДНЕГО КАЧЕСТВА,С ВЫХОДОМ КАМЕНИСТЫХ ПОРОД,заросший 10% ИВА ДРЕВОВИДНА,ФОНД РИК\n"
"ЗАЛИВНОЙ,СРЕДНЕГО КАЧЕСТВА,С ВЫХОДОМ КАМЕНИСТЫХ ПОРОД,заросший 10% ИВА ДРЕВОВИДНА,ФОНД РИК\n"
"заливной,среднего качества,чистый,заросший 10% Береза белая,урожайность 0,7 т/га,Служеб.надел лесн. охр.\n"
"заливной,хорошего качества,покрытый кочками,заросший 10% Береза белая,урожайность 0,6 т/га,Служеб.надел лесн. охр.\n"
"Служеб.надел лесн. охр.,среднего качества\n"
",среднего качества ,Служеб.надел лесн. охр.\n"
"суходольный,среднего качества,чистый,заросший 15% Ива,урожайность 0,1 т/га,1\n"
"суходольный,среднего качества,покрытый кочками,заросший 5% Береза белая,урожайность 1,0 т/га,1\n"
"суходольный,среднего качества,заросший,заросший 5% Береза белая,урожайность 1,0 т/га,2\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.