use strict;
my $str = 'заливной,чистый,заросший 30% ИВА КУСТАРНИКО,урожайность 1,0 т/га
суходольный,низкого качества,покрытый кочками,заросший 10% береза белая,урожайность 0,6 т/га,подсобное хозяйство
заболоченный,среднего качества,покрытый кочками,заросший 20% ольха кустарни,урожайность 0,5 т/га,служеб.надел раб.и сл.
ЗАЛИВНОЙ,КОРЕННОГО УЛУЧШЕНИЯ,заросший 10% ИВА ДРЕВОВИДНА,урожайность 0,5 т/га
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЧИСТЫЙ ,урожайность 1,5 т/га,СЛУЖЕБ.НАДЕЛ РАБ.И СЛ.
заболоченный,среднего качества,покрытый кочками,заросший 5% ольха,урожайность 2,0 т/га,служеб.надел раб.и сл.
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 10% СПИРЕЯ,урожайность 0,3 т/га,СЛУЖЕБ.НАДЕЛ РАБ.И СЛ.
суходольный,низкого качества,заросший,заросший 40% Спирея,урожайность 0,1 т/га,Фонд администрации
суходольный,среднего качества,чистый ,урожайность 0,5 т/га,Фонд администрации
заболоченный,среднего качества,заросший,заросший 5% Осина,урожайность 0,7 т/га,Служ.надел раб. и служ.
заливной,низкого качества,покрытый кочками,заросший 20% ива.древовидна,урожайность 10,0 т/га,служеб.надел лесной охр.
суходольный,среднего качества,чистый ,урожайность 1,0 т/га,фонд рик
заболоченный,среднего качества,покрытый кочками,заросший 30% Береза белая,урожайность 1,0 т/га,Фонд администрации
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 40% БЕРЕЗА,урожайность 0,5 т/га,ФОНД АДМИНИСТР.РАЙОНА
суходольный,среднего качества,чистый,заросший 10% Береза белая,урожайность 1,0 т/га,Фонд администрации
заболоченный,среднего качества,заросший,заросший 10% Ива,урожайность 0,5 т/га,Служеб.надел лесн. охр.
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 10% СПИРЕЯ,урожайность 0,3 т/га,СЛУЖЕБ.НАДЕЛ РАБ.И СЛ.
заболоченный
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 20% ИВА КУСТАРНИК.,урожайность 0,6 т/га,ФОНД АДМИНИСТР.РАЙОНА
заболоченный,среднего качества,заросший,заросший 10% Ива,урожайность 0,5 т/га,Служеб.надел лесн. охр.
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 40% БЕРЕЗА,урожайность 0,5 т/га,СЛУЖЕБ.НАДЕЛ ЛЕСНОЙ ОХР.
СУХОДОЛЬНЫЙ,СРЕДНЕГО КАЧЕСТВА,ЗАРОСШИЙ,заросший 30% БЕРЕЗА,урожайность 0,6 т/га,ФОНД АДМИНИСТР.РАЙОНА
ЗАЛИВНОЙ,СРЕДНЕГО КАЧЕСТВА,С ВЫХОДОМ КАМЕНИСТЫХ ПОРОД,заросший 10% ИВА ДРЕВОВИДНА,ФОНД РИК
ЗАЛИВНОЙ,СРЕДНЕГО КАЧЕСТВА,С ВЫХОДОМ КАМЕНИСТЫХ ПОРОД,заросший 10% ИВА ДРЕВОВИДНА,ФОНД РИК
заливной,среднего качества,чистый,заросший 10% Береза белая,урожайность 0,7 т/га,Служеб.надел лесн. охр.
заливной,хорошего качества,покрытый кочками,заросший 10% Береза белая,урожайность 0,6 т/га,Служеб.надел лесн. охр.
Служеб.надел лесн. охр.,среднего качества
,среднего качества ,Служеб.надел лесн. охр.
суходольный,среднего качества,чистый,заросший 15% Ива,урожайность 0,1 т/га,1
суходольный,среднего качества,покрытый кочками,заросший 5% Береза белая,урожайность 1,0 т/га,1
суходольный,среднего качества,заросший,заросший 5% Береза белая,урожайность 1,0 т/га,2
';
my $regex = qr/^(?<FIELDTYPE>[А-Яа-я. ]+){0,1}(,[ ]*+(?<QUALITY>[А-Яа-я. ]+)){0,1}(,[ ]*+(?<FIELDCONDITION>[А-Яа-я ]+)){0,1}(,[ ]*+заросший[ ]+(?<OVERGROWINGCOVERAGE>\d+)%?[ ]*(?<OVERGROWINGTS>[А-Яа-я .]+)){0,1}(,[ ]*+урожайность[ ]*+(?<PRODUCTIVITY>(\d+,\d+))[ ]*+(т\/га)?){0,1}(,[ ]*+(?<USERTYPE>[А-Яа-я .]+|(\d+))){0,1}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}