$re = '/(^\+447|07|00447)\d{9}$/';
$str = '+447908846658
07908846658
00447908846658';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);