const regex = /(^\+447|07|00447)\d{9}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\+447|07|00447)\\d{9}$', 'g')
const str = `+447908846658
07908846658
00447908846658`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}